Problems with Setup and Connectivity

Post all your problems setting touchAble Pro up or connecting touchAble Pro with your Ableton Live

Thanks guys! Beginning tests right now but I’m not seeing the +6b option for the faders. Where is this option now?

Not able to set up connection between Server and the App. I installed the server, the script, rtpMIDI, the Mobile Device Driver and Bonjour as explained on the website… when starting the Server and I right click it, it says Control Surface Responding: Yes - however when I start the touchAble Pro app I get no Available Devices (USB/WiFI) nor Active Connections at the server. It shows 0 every time…

What to do??

Well after install server and script my view is different as your web and pdf manual. I dont have a “touchable pro” script…just “touchable” . And 2 input-outputs: “touchable” and “touchable control surface …”. ???. which i should select! ??. Windows 10 64 bit/ Live 10.
ANother thing: i’ve own “touchable 3”…i didnt uninstall the touchable 3 server-script…i should do it? or are independents?
Clipboard%20Image Clipboard%20Image%20(1) Clipboard%20Image%20(2)

First impressions are excellent guys! Great Job :slight_smile: Haven’t yet dive into the custom section, I’ll leave this part to the end.

Anyway I’ve found some bugs.

  1. Watching the Manual I’ve noticed that in page 11, the 6th button of the Main Bar the logo is different from what we see in the App.
    While in here it also appears that “Global Groove” changes aren’t being reflected in the main LIVE’s Groove upper section.

  2. Previously while in mixer mode, double tapping at the bottom of a volume fader would snap to the minimum (-Inf db). In the Pro version it appears that double tapping only works for the maximum value which is (0 db).

Regarding this there used to be a button for +6db in TouchAble.
Looking at the App I can’t seem to understand if the “0db Active” button is supposed to do this because when pressing it and double tapping at the top of the fader always snaps to 0db instead of +6db

While in mixer mode and “Bottom Bar” I see two buttons “Prev. Track” and “Next Track” and another “Jump Size”, Haven’t found nothing in the manual regarding this so what is it for?

  1. Loading big Drum Racks (64 Pads) each pad loaded with 127 samples causes Touchable Pro to not work showing: “Control Surface Not Responding”
    This happens both in Live 9 and Live 10.

Worth mentioning maybe as I was confused by this as well as one of the above posters - the documentation/screenshots here:
http://zerodebug.com/touchAblePro.php
show some things labeled/named as ‘touchable pro’ - whereas what we as users/testers have atm (and what tripped me up when troubleshooting a connection issie [turns out you now have to also ‘click’ on the connected PC in Touchable on the connection pop-up… without that touchable just stared at me blankly…] ) identifies itself everywhere as just ‘Touchable’ or ‘Touchable Control Surface’, but no where as ‘Touchable Pro’ afai have seen.
To avoid confusion when troubleshooting, might be worth to unify and name things consistently in app & documentation now that there are more testers/users coming on board ?
Churs.
c.

I think a lot of users will be switching from touchable 3, the ambiguity around control surfaces confused me for about 6 hours of use. It’ll be worth idiot proofing the set up guide to avoid AppStore and forum rage.

Can’t get touchAble Pro to see the server, running on Windows 10. Installed bonjour and the drivers as it says in the guide. Installed the server and the control script, setup midi settings properly in Ableton…

In touchAble it just never finds the server, I’ve got everything opened up in windows firewall… Any other things to try?

Hi, have checked if the server is running? If you are connected via WiFi, please make sure to connect to the same Network as your mobile device.

Hi, have checked if the server is running? If you are connected via WiFi, please make sure to connect to the same Network as your mobile device.

Yes the server is running, says Control Surface Responding: Yes

Both devices are On the same WiFi network

Could you please try to connect via USB? Btw. are running an iOS, Win or Android touch device?

It’s an Android Device, does over USB? I was under the impression that it wouldnt

That impression is absolutely right :). We had a similar issue while testing, because i renamed my machine. After renaming it again, restarting the router and the Desktop it worked again, which is not a very convenient solution and sounds more like voodoo. We will do some more tests, and get back to you as soon as we found a more consistent solution to that problem. Thanks for the feedback and sorry for the inconvenience.

1 Like

Hmm i will try that and some other things on the router tonight if i get a chance

We have invited a friend to shoot a video today and encountered the same issue again with his laptop (Android Smartphone <–> Mac Book Pro). So we hope to narrow down and solve the issue today.

I am also having problems with connectivity with my android on windows… Very similar issue from the ones presented on this forum but couldn’t seem to see a clear solution for the problem. Are there any plans for an update on the windows server? This is unfortunate because i was really looking forward to working with this app… even went as far as buying a tablet to be able to increase my work-flow. I really hope that this issue is a top priority for you guys, if not i would be highly disappointed.

Hey Nuon,

as far as we know the connection issues - especially Android - have been solved already.
Which Server version are you running on Windows? Which build of the app?
Please check the Task-manager to see if the Bonjour Service is running - and start it if not.
Cheers!

To clarify: the issues in this thread have been of different nature and came down to different bugs.

I am also having problems with connectivity with my iPad on Mac.

“Connection Status” are…
V.417 SRV (Green)
V.412CS (RED !!! )

OSX 10.11.6
mac mini (Late2012)
LIVE 10 10.0.5

touchble pro beta 0.9.915
iPad Pro9.7 inch
iOS 12.0 (16A366)

I want to know the meaning of “CS”.
what can i do with it ?

PNG 15

…shouldn’t the control surface be set to “touchable”…?..