Setup Instructions Windows

Windows:

  1. Please download and install the Servers (see other pinned topic for latest version)
  2. Find the touchAble icon in the system tray and right-click on it.
  3. In the popup window, select ‘Install Script’ - and point it to your Ableton Live installation.
  4. Click Install.
  5. Restart Live.
  6. In Lives MIDI / Sync settings - please select ‘touchAble’ as a control surface.
  7. This next step is crucial: Please select the Track & Remote settings for the midi ports exactly as pictured (please disregard that the Control Surface should actually be named ‘touchAble’):

controlsurfacesetup

you should now be good to go :slight_smile:

If you can’t find a Server at all - please check if you have a firewall or packetblocker running that might be interfering.
If it keeps saying ‘Control Surface not responding’ - please restart Live and check if everything is setup correctly.

If everything should be alright - please send us the Log.txt that is saved by Ableton Live:
\Users[username]\AppData\Roaming\Ableton\Live x.x.x\Preferences\Log.txt

To make 1000% sure this is not the source of troubles - could you add a screenshot of the ‘Output’ switch routing too ? (which I assume to be all off… ?).

Cheers.
c.

Using touchable on the same machine is still not possible,there is no connection…my ipad works just fine

touchable touchable%202

These are screen shots of the connection issue using an external monitor in windows

Yes I have the same problems with Windows with an Surface Pro 4 … never got it run. Always the message that there is no connection …

With different iPads it works pretty good

Mclevit was able to run by now - did you update to build 8.12 yet?

As my post got highjacked and you are discussing connection issues on Windows here:

Same problem, no connection with Windows, build 8.12.

I used https://hobbyistsoftware.com/bonjourbrowser to see what’s going on Bonjour-wise in my network. The server seems to be ok, Bonjour Browser sees it on the server PC itself and also on my app PC. The Windows app is NOT showing up - not via network on the server PC and not even on the app PC itself.

So problem seems to be the Windows app not establishing a proper Bonjour service.

Double checked everything with TouchOSC Bridge and everything shows up and works as expected.

Iqud, don’t know if this is helpful for Christian, but maybe you could also run
https://hobbyistsoftware.com/bonjourbrowser on your Surface to see if you also
see no Bonjour activity of TouchAble.

Hey Coupe,

sorry - i meant to get back to you earlier.
The Bonjour information you found do not indicate a problem - in fact, everything looks alright, that’s what’s puzzling.
The App itself is not supposed to show any bonjour activity - it is merely passively receiving that information from the Server so it knows where to connect. And since bonjourbrowser sees the Service, the information reaches the Computer that the app runs on.
It seems that at some point in the discovery process the windows app either is not informed of the Server in the network - or fails to resolve it’s IP address completely.

Unfortunately these issues have ceased with 412 on our internal test-rigs, so we are digging in the dark a bit.
I will upload a build tomorrow that enables the console - it will hopefully show some more information about where in the process it goes dark. Could you try that and help us out debugging this?
I’ll take it to pms from here

Cheers,
Chris

any luck with finding a solution? I also using the window store version and getting no connection

Waiting for the update to go through - we have fixed a few things and hope they solve this


Ableton live beta 10.1.9 last
Windows 10 home 64 bit
Touchable pro beta last release
Server beta last release
IPad Air with iOS 12.4.3

Problems: only works the note mode and on the screen you can see how the bar count is sync and ok but you can’t see the clips, can’t start stop etc

We think this might be a problem with the script and working on a logger for the script at the moment. Sorry for the inconvenience.
Best

If you need info or some logs just tell me and i can send to you.

As I got a new computer, I added Touchable right away, before any other gear (but the Push2, which was set up/tested previously, but is off…).
And, even though I followed the setup & settings instructions:


to a T - it simply does not work.

Now, it’s slightly different. No connection to master fader anymore either. Despite Win Server claiming>
Control Surface Responding: Yes
and
Active Connections: 1

plus iPad app stating:
status: OK

Anything you want me to try - now that I have a computer with barely anything installed yet, and touchable still not playing nice…!?

Churs.
c.

ps. also, rtpMidi now installs the latest available Bonjour version (2.0.2)…

One thing to confirm - is there anything to set up in rtpMidi ?
I’ve tried both options I could see, i.e. - with DESKTOP-**** activated, and without.
Both behaved the same.

pps. another 15 minutes of attempts, looks like what was needed was:
rtpMidi - needed PC activated, and iPad activated as a participant in the same session.
PLUS, and this was the missing bit I only discovered by accident:
iPad App - Connection Status needs to be hit/.touched in the center of the pop up once. It then loaded all clips and seems mostly functional as is (atm). If I have time the enxt days, I’ll test some more, adding move devices to the mix…

c.

ppps.
spoken too soon yet again. Looks like only:
Touchable -> Live
works. But
Live -> Touchable
does not.
:confused:
Also, clip timers (the circular/clock-like colour change) aren’t shown in Touchable anymore in the current state as is - looking as if Live is not running, when it is…
c.

pppps.
Even though I tried this before to no avail for this issue, now that I hit ‘iPad App - Connection Status’ yet again, hit/touching the center gave touchable the necessary nudge, and it started to act in sync again…
Odd and odder…

Hi.

thanks for the detailed feedback.

as far as i got every detail:

connection between server and mobile device seems to be working constantly, but the script doesn’t respond reliable?

Could you please try to activate the log option and restart Live and the mobile device app afterwards (server context menu -> log mode: on/off) and send us the logfile:

C:\Program Files\Zerodebug\touchAble

Best

Pascal