Cannot get Control Surface to respond

I’m hoping this is the place to post issues with connectivity (a little concerning there’s little posting here for 5 months??). I posted within the connectivity thread but posting here too in case that is buried.

I’m battling to get Touchable Pro to connect. I have the server installed and scripts installed for Live 10.1. Running windows 10 on a laptop. I have the touchAble control surface available and set-up in Live with the Touchable script as input. Midi remote and retrack enabled for touchable, nothing for touchable script in the set-ups.

The server recogises my ipad and iphone via wireless and 2 devices can be seen. Both of them report the following under connection status:
v.428 SRV DAW-LT1 Live 0.0.0
Control Surface is not responding.

Can anyone suggest next steps in trouble shooting?

btw - I have run touchable 3 in the past and had it connecting so am familiar with the previous set up requirements.

Just thought I’d post an update that with a bunch of messing around I did manage to get the Touchable Pro up on the ipad…briefly, then it crashed ableton and I had to restart. I have not succeeded since despite a whole bunch of different combinations of start up sequence, reboots, checking out rptMIDI (is this needed? If so what settings. Documentation is mute). HELP!!!

Is this forum monitored by any support people. Desperate to get this working.

Hi,

sorry for the inconvenience. Could you please post your log here?

Windows Vista, Windows 7, Windows 8, Windows 10
\Users[username]\AppData\Roaming\Ableton\Live x.x.x\Preferences\Log.txt

Windows XP
\Documents and Settings[username]\Application Data\Ableton\Live x.x.x\Preferences\Log.txt

Mac OS X
/Users/[username]/Library/Preferences/Ableton/Live x.x.x/Log.txt

We are currently preparing a big update concentrating on connectivity and stability and hope to iron out all those issues within the next update.

Best

Pascal

Hi Pascal,

That’s no problem, I’m just glad to know you guys are working on this issue. I was beginning get worried. My log file is attached below. Cheer Steve

I cannot see how to attach a file. Where do I do that??

Ok - here’s a dropbox link to the log file:

Hi Pascal,

I have had some success this morning. I previously updated the Touchable .py file you provided another user in another post, and that did not help. However this morning I am about to be out of the studio for 3 days and so was prepping my laptop to take on the road, and have managed to find a consistent way to achieve connection.

In the past I have been starting the server 1st, then Ableton, then OS Touchable. That always resulted in UNable to connect to COntrol Surface Live 0.0.0 issue.

Now if I start Server, then Ableton, then Touchable OS, then quit server and restart, I get connection 100% of the time.

I thought I’d let you know in case it assists your trouble shooting.

Some things to note, this is without having the control surfaces for MPK225 Connected or Push2…ie no other USB connections. Might be relevant???

Also, just tested, I do not need to do the server start/quit process. What works fine now is Start Live 10.1, Start Server, Start iOS App on ipad or iphone…100% success!!

I will test my full live set-up with other control surfaces also active when I return from the break. At least I have a functioning system right now.

1 Like

HI all

Here is what i did to solve the problem:

change firewall from public to work or home
quit touchable app ( because it says Control Surface responding: No)
open live 10.1
reopen touchable app
it now says Control Surface responding: Yes
you may need to restart LIve
now it all works!!!

1 Like