Connection Problem: touchAble Pro (WIN 10) + Ableton Live 10.0.5 (macOS 10.14.2) w/ Server 425


#1

Followed setup procedure exactly with no problem.

The WIN10 version usually connects and works for about 15 seconds or until I select a different icon on the UI. It looks like it’s connected but communication with the MacBook ceases.

Another way to make it break is by folding the WIN10 device into tablet config. Instant death.

I have used touchAble on iOS for a long time with no issues so this really surprises me. I had an unused Lenovo Yoga 13 that I thought could make a nice touch control surface (instead of the iPad) so threw down the cash for another version of touchAble. touchAble Pro on WIN10 simply doesn’t work with the Mac. I have tried with and without server activated on the WIN10 device per the ambiguous setup instructions.

N.B. touchAble Pro works fine if I control Live 10 on the same WIN10 device. I have been unable to make it break there. touchAble Pro on iOS also appears to be unbreakable.

What’s the solution?

P.S. Also hoping someone frome zerodebug (what a name…) might be also able to eventually address the Studiomux issue I’ve requested help with.


#2

you are right - the name stops being funny once we encounter issues like this…
we are on it! the app shares most of the code across platforms, so the culprit is in some of the system layers we built for our framework. we received a few mails about similar issues and we will try to get it fixed as soon as possible.
If possible - please send us any crash reports / event manager logs you can find - it will help us to find the cause!

we’re very sorry for the inconvenience guys - hope to be back with better news soon!


#3

ps: saw your post about studiomux as well - same applies here - trying to reproduce and fix it asap! we’ll update your thread as soon as we know more!


#4

Hi Christian, I don’t seem to have any crash reports and I’m not sure about event manager logs. touchAble doesn’t actually crash – it just stops working. On the Mac side, Ableton Live 10 is still controllable by regular methods, just the touchAble app on WIN10 ceases to control anything.


#5

Any new information on this? It still doesn’t work for me. It’s quite frustrating and a seemingly a waste of money.


#6

I started messing around with trying to get this working again and may have found a solution. AFAIK, this point is not mentioned in the setup instructions.

I was able to get the connection happening without breaking when I changed the status of the shared WiFi network to ‘Private’. It was previously set to ‘Public’ for security reasons. I just had the app working without interruption for more than 10 minutes straight. Hopefully it will continue to work and I hope this may be useful information for any other users who have experienced the same problem.

I also updated the server to v426 but I’m not sure if this had any bearing on the issue.


#7

Hi, sorry for the late reply and thanks for the feedback. We will do some more testing with the network settings you recommended. And will add it to the manual.