Liveset still won't load (server 423)


#1

Hi guys,

My liveset is still not loading.
I’ll try to help you narrow it down from what I’ve experiencing here.

So first things first:
If I open a clean Liveset Touchable opens without any problem.

So back to my Liveset:

The connection Status shows that both the Server and Client are connected but I get no visual display on the iPad.

If I press Play from the Transport in Touchable Live starts to play so the connection is happening.

A made a test which was to delete all tracks on my Liveset to the point where there is nothing left just to see if Touchable Pro would load, but unfortunately it still doesn’t.

This is strange because it’s the same as a clean set so I can’t understand why this happens… Can you guys please help me here?

Thanks


#2

Hi,

could you maybe send us the emptied set, that is not loading? Maybe some Live configurations cause touchAble not to connect and load properly.

Best

Pascal

http://help.touch-able.com/


#3

424 should do the trick :slight_smile:


#4

Hello,

I’d like to give some input in this topic too. I have the same (or very similar) problem.

tldr: I could not load BIG ableton projects on touchable with server version 420, I still cannot with 424. Small project load fine.

I work with a huge ableton project, which I use for my live performances. I have been using touchabe for over three years now. With touchable V3 any kind of such problems did not occur, I only used to sometimes have difficulty connecting, but once connected all worked well. Maybe a week ago, I’ve ran into connectivity problems again and found that there is this new version touchable Pro and tried to install it. So small projects load fine. They load perfectly with touchable V3 on iPad and with touchable Pro on the same iPad (both using the new touchable pro server v420). When I load the big project I was talking about, touchable V3 (iPad) just crashes and shuts down and touchable Pro kind of loads, but I cannot see any of my tracks, volume sliders and so on. Just like the OP, I can press PLAY and STOP, but nothing more.

Getting ready to post here on the forum, a couple of days passed and I’ve found this thread. Got excited, as I found that the latest version for the server now is v424. However, I’ve tested the new version (done reboots, script reinstalls, updated iPad app) but all seems the same regarding my problem.

I have not tried to delete all tracks in the big project, like the OP did, but all newer and lightweight projects load ok.
One more detail, which may help figure out the problem is: When touchable fails to load a big project, I cannot see the “red square” in my macbook ableton window. (The one that outlines which tracks are visible in touchable on the iPad. Maybe because nothing is visible on the iPad.)


#5

Hey zinkus, any chance you could send us one of the sets in question? samples etc do not matter, just the general structure & devices are enough to test it.

We unfortunately found a small issue with compatibility between v3 and server 424 - so that crash is noted and fixed for the upcoming update of v3. However: touchAble Pro should load - and as far as i’ve heard, it does load fine now for the OP. We’ll take a look and hope to be able to fix this in the coming days!

Which iPad are you using Pro on?

Thank you!
Chris


#6

Hey zinkus,

we just found a pretty stupid typo in the mac script - could you give this server & script a try please?

Thank you!


#7

I’ve just posted my project in the discussion section. But I will check 425version now and report back.


#8

it won’t work with v3 at the moment - but touchAble Pro should finally load completely.
We’re updating v3 at the moment to be compatible with the new Server again.

Got your mail - testing your Set here as well now :slight_smile: looking good on an iPad Pro… but it might be a tight fit for the ipad 3 (atm it takes >1 gig of ram while testing, we are working on getting this down right now.)


#9

I checked, so its not 3rd gen iPad. both are 4th gen. However, with server v425 it still failed to load. Still not showing the red square on macbook ableton screen.

by looking good do you mean that you can load this set on iPad Pro and see all the clips?

Edit: I’ve just found that there is no red square in the project that loads successfully :slight_smile:


#10

yea - without issues and rather fast actually. did you restart Live after installing the scripts?


#11

Yes. I have downloaded the v425, rebooted the macbook. Then before opening ableton I have reinstalled the scripts and then launched ableton. A cut down version of the same project you have (cut down to ~2% of the project I sent) loads fine…


#12

Yea i’m pretty sure it’s about the memory usage then - it’s a bit out of hand for the clips at this time - so these 50.000 break the 1gb limit of the ipad 4 - we’ll cut this down to a minimum and let you know as soon as possible


#13

Ok, I’ll be waiting to hear from you. However, I’ll repeat one point: This same project used to load fine with the V3 version. So there must be a way to fix this issue on touchable Pro.

Edit: one more thing. Now toucheble Pro on the iPad loads to the same point where it used to earlier (allowing me to press PLAY and STOP, but with great lag) and then crashes. It seems like as you say, it runs out of RAM. But surely RAM management went sideways at some point on transition from touchable V3.


#14

v3 is using less memory per clip than Pro at this time - that’s why you only see it crash on pro - we were a bit too generous with adding Parameters, but we’re remedying that issue just now!


#15

Any news? :slight_smile:


#16

very good news in fact! We were able to drop up to 75% of memory on very big sets, and they will run fine on older iPads now (i will count 4th gen as older only because it is limited to 1gb ram :wink: )
We’ll have it up in a few days!


#17

!!! you are crazy guyz !!! that’s a really good news for all ipad owner !!!


#18

Hello again. I am glad to hear that you seem to have solved the memory problem. However, today I also received a reply to my project upload, from when I uploaded for you to test. The reply also states, that you were able to reduce memory usage by 75%.

The problem is that I cannot see any new MAC OS server updates. The latest version is 425, which we tested 10 days ago. Am I wrong to expect to find a new server version after these two replies stating to have the problem solved?

Thanks!


#19

The memory issue was only an issue for the app - we were able to keep the Server & Scripts compatible with that new version, too. So no need to update the Servers at this point - but please make sure you got the latest app version installed :slight_smile:

Please keep us posted if this finally helped!
Cheers,
Chris


#20

Hey, so just updated and tested my big project - loads nicely :slight_smile: Thank you for the active support in this matter!

Just as a side question as I have you here: Would it be possible to fix touchable V3 app to load? Or maybe it is planned in the not so far future?