More Studiomux woes. Please, Zerodebug, listen.

Long post ahead…

Over the last months, I have spent considerable time delicately optimizing SMUX/AUM on iOS for use with Ableton Live 10. I have found the only clean solution is to use the SMUX 18in/2out device and ‘External Instrument’ devices in Ableton Live 10 (aggregated with another interface). This has been work in progress as I’m trying to figure out best practice to have access to the cream of iOS synths/FX and the presets therein from inside Live 10. The computer is a mid-2015 MacBook Pro on the final version of Mojave 10.14.6.

My usual ‘critical’ sequence of startup was:
-Check SMUX Server is online in Mac;
-Connect iPad Pro via USB;
-Open AUM on iPad Pro then load the saved AUM Set;
-Launch SMUX from within AUM (tap SMUX icon in AUM channel)
-When SMUX opens, launch saved SMUX set.

If I followed this sequence exactly before I launched Ableton all the necessary MIDI/audio channels were visible. If I tried to open SMUX first, sometimes trouble ensued and things went awry — i.e. MIDI channels allocated to devices don’t show up properly in my Live sets and the channels of the audio device get deactivated by Live 10.

Everything was working fine like this until I updated good old reliable AUM today. Now some strange stuff happens - unless I’m dreaming or forgetful:

  1. If I open a saved set in AUM (with SMUX routing baked in) it will launch SMUX when I click on the SMUX icon within an AUM device but when SMUX opens it will not allow the 8th channel in SMUX to be anything but Audiobus! This cannot be changed back to IAA which is vital for my set.
  2. SMUX now will not launch my saved SMUX routing (AUM Channels 1-8)! It completes loading but remains empty.
  3. Obviously MIDI ports are not appearing in Ableton Live…
  4. If you launch SMUX first (and only SMUX) you can have an IAA channel without a problem. But if you then try and launch AUM from within SMUX it may/probably will fail.

This app is killing me. People would pay 5 times the asking app price if only it worked consistently and nicely with other apps!

Messed up stuff about SMUX:
-SMUX VST/AU is ‘sort of half-broken’ and won’t allow the sending of any other MIDI on/through the same channel in Live (no MIDI from clips in Ableton, no routing in external controllers like you would with any other VST even from other channels)
-Only VST/AU works reliably for using an iOS device as an external effects processor - trying to use the SMUX audio device only, the signal seems to only find its way in on Channel 1 and 5 - external Audio Effect in Live fails;
-Audiobus integration hasn’t ever worked reliably…so many crashes.
-SMUX IAA Auto Launch is always enabled even when it’s turned off.
-SMUX often freaks out and steals all RAM…all of it!!!
-SMUX on iOS takes it upon itself to mute all channels when I open it nowadays and defaults the iOS monitor to ON. Why???
-Ableton Link is botched and the transport is useless.
-Some AUv3s crash SMUX iOS (Dubstation 2 for example…)
-The buried icon menus are counterintuitive and infuriating.
-Sometimes the VST/AU won’t allow you to select the connected iOS device.
Did I miss anything? EDIT: Yes…
-Can’t delete saved presets from within the app.

Ultimately after buggerizing around with the whole thing for HOURS I have found a solution to make sure SMUX won’t fail:
-Open SMUX, change CH. 8 AB to IAA, DO NOT open a saved set!;
-Open AUM, load AUM Set, click on one of the SMUX icons in the loaded AUM set to flip back to SMUX;
-Back in SMUX, launch the relevant saved SMUX set (in my case it’s simply each channel (1-8) populated with an AUM Channel (1-8);
-If I do this my Live 10 set will open fine and there will be SMUX audio/MIDI available.

This works…for now. I do not understand why users have to chant a secret mantra while performing an arabesque as they simultaneously face Northeast at exactly 11:59:59 p.m. (and not a second later) to get this audio/MIDIecosystem to work.

Zerodebug, I can only hope you are listening…