Phone not detected


I just purchased studiomux so that I can use Ableton to route midi into my iphone and have the audio come back into ableton.
Note I have tired emailing supoort before posting this, but email bounces back. There doesn’t seem to be a way to get in touch with support.

I’m reading the manual.

It’s very unclear what needs to be installed. Is it just studiomux server, or do I need midimux also?

A lot of the pages on the website don’t load properly.

I found this page.

Is this the only thing I need to install?

Opening the studiomux app on iphone - it just says - loading studiomux. Nothing else happens.

Is this normal?

Reading the manual:

“The studiomux VSTs are not installed by default,
please right-click the Studiomux icon in the taskbar and select Install 64-Bit
VSTs or Install 32-Bit VSTs depending on your current Windows version.”

Firstly, what are the studiomux vsts? Does studiomux have it’s own vsts?

There is no option to install 64 bit or 32bit when I right click on the icon.

But when I do click on it, it says 0 devices detected, despite my iphone been plugged into computer.

It does appear under vsts in ableton, which is good, but I can’t do anything with it, as it does not detect my iphone.

Let me know what to do as it is very confusing.


sorry for the late reply. Unfortunately the current studiomux version does not run on the latest iOS. We had to rewrite big parts of the app and are currently in the last phase of the beta for the new studiomux version.

The update will be release on the 1. of August. In the meantime we offer anyone to join the beta:

Details about the current state of the beta and server downloads can be found here:

We haven’t yet finalised the Manual for the new version.

I will try to guide you:

Please install the latest beta server and app first. Start App and Server, add the StudiomuxInstrument VST3/AU from Abletons plugin category.

From VST/AU:

Select your device from the device list and the Channel from the Channel list.

From Studiomux iOS app.

Open the Browser, select the ‘In’ category and find your plugin. Drag these plugin onto the track, you receive audio via VST.

Thats it. MIDI Ableton will be transmitted to studiomux -> IAA/Auv3 App and Audio send back to Live.

I attached two screenshots, demonstrating the setup. In Live’s track Nr.1 i loaded the studiomux instrument receiving audiom from studiomux’s channel 3. In studiomux i loaded the Viking AUv3 in channel 3.


THanks for the guide.
Still a lot of problems though.

I downloaded the latest studiomux server.
This time it automatically copied the vsts, which is good.
After starting the app and server
App - It permanently says “loading studiomux”?? It never actaully opens on phone. I have reinstalled it but still the same.
Opening server - The icon appears on bottom right, but no GUI opens. Is this normal?

“add the StudiomuxInstrument VST3/AU from Abletons plugin category” - I can do this, but…
when I try to select my device, in the dropdown, it says:
Select device
Select device

If I click the first one, nothing happens, if I click 2nd one, ableton always crashes.

If I right click the server icon on bottom right, it doesn’t detect any devices, despite my iphone being plugged in and detected by itunes.
Any ideas/

Just to add,
the app did start up properly after I restarted the phone, but the rest of the suggestions didn’t work.
It doesn’t detect the phone.


could you please let me know, which server and app version you have installed?

Please make sure to install the latest server and app both 5.099. Also please try to unplug your phone after after restarting your machine.



I can’t find the download page to check. I did it 3rd August I think. So whatever version that was. Might be 5.098?
I will try this one again

Just tried all that after resinstalling server, restarting machine and plugging out / in phone.
Same problem.
The server just doesn’t detect the phone. When I right click on the server icon , available usb devices is always 0.


Please try to completely delete the studiomux App from your iOS device and reinstall it. On reinstall you will be asked to allow studiomux to communicate over network, please grant those permissions. After reinstall please try to reattach your device.

I also just tested the usb connection on windows with different versions of itunes, it worked well with the latest iTunes, downloaded from Apple and from the Microsoft store. In case you haven’t downloaded iTunes from one of those sources, please update iTunes.



Hi stephenhiggins,
excuse me, if I am wrong, but when reading this, it seems to me, that you are trying to use the old appstore version of studiomux. Did you install beta via TestFlight?

No, how do I do that? is testflight an app?

Join the studiomux beta

Available on iOS
Install this on your iDevice…

Also, read this thread on the forum for more info;

Yes, exactly as iso wrote.
Once you have installed testflight, you will see the invitation for installing studiomux beta.
And before you do that, it is a very good advise, as Pascal wrote, to delete your current studiomux app from your iOS device. I did that too, and it solved some problems I had before.
Good luck!

Thanks for the replies.
I have uninstalled studiomux app and downloaded testflight.
I can’t tell from the posts if I should just reinstall studiomux app again?
Or try Join the Beta.
The problem when I click on the join the beta link is:
“To join the studiomux beta, tap the link on your iPhone or iPad after you install TestFlight.”

  • I don’t see any link on my iphone for this? Is it supposed to appear somewhere?

Installing a Beta iOS App via Email or Public Link Invitation

  1. Install TestFlight on the iOS device that you’ll use for testing.
  2. Open your invitation email or tap on the public link on your iOS device.
  3. Tap View in TestFlight or Start Testing; or tap Install or Update for the app you want to test.

Join the studiomux beta

You have to join the beta – which is just a matter of tapping a link and then tapping another button after TestFlight launches when you tap the link to the open beta

  1. Open your invitation email or tap on the public link on your iOS device.
  • I never got an invitation email, or don’t see any public link on my iOS device?
    When I open testflight, it just says - No Apps available to test.
    There is no link or anything that I can tap on?

Join the studiomux beta

This is the public link. You have to open it on the device you have Test Flight installed on. WiFi or moblie data will need to be turned on. There isn’t an email invite for this, becuase it’s open to anyone who wants to use it. The link above is the invite.
I will test the link myself in a bit to make sure it’s still working…

A little popup came up on itunes when I plugged the phone in. I opened testflight, but nothing.
The popup doesn’t appear any more when I open itunes with phone plugged in.
Wifi is turned on of course.
I try clicking on the join link above, nothing happens.
Maybe if anyone had a screenshot to show me where this link is supposed to be appearing on my phone.