Problems with connectivity


#1

Hi, I have am running the touchable server 64 in a windows 10 with ableton 10, and I have the touchable app in an ipad 2018. The touchable server shows “Control surface responding: Yes” and “Available devices: 1”.

These are my settings for live are the same that shown in the touchable guide

And this is what I see in the touchable app:

TouchsbleMessage

seems to be a problem to recognize ableton from touchable.
Has anyone has similar issue, or any idea of hoe to fix this.
I already installed the softwares and the scripts.
Thanks


#2

Hi, I have exactly the same problem. Have also re-installed scripts and server several times.


#3

Hey guys - could you please send us the Ableton Log.txt ? They will hopefully show where the issue is

you can find them on Windows:
Users/[your username]/AppData/Roaming/Ableton/Preferences/Live X.X.X

Thank you!


#4

Hi Christian,
Thanks for your reply. Here find a link to a folder with the ableton and touchable log files.
Let me know if you need more information.

Logs Folder

Thanks


#5

Hi Christian,
Is there anything you could find out in the logs?

Thanks for your help


#6

Hello I’ve exactly the same problem with ipad 6th generation during a session… no problem during one hour, then suddenly all the connections were suddenly off ! No way for restart touchable 3 and refind the connection. Any idea, is it a knowing bugs ? A way for fix it ?!? Best


#7

I’m having the same problem with the 424 version of the server. Relevant excerpt from logs:

9467 ms. RemoteScriptMessage: (LK) Initialising...
9472 ms. RemoteScriptMessage: LK - Version 2.6
9477 ms. RemoteScriptMessage: LK - Ready!
9497 ms. RemoteScriptError: Traceback (most recent call last):

9502 ms. RemoteScriptError:   File "<string>", line 1, in <module>

9507 ms. RemoteScriptError:   File "MIDI Remote Scripts\touchAble\__init__.py", line 33, in <module>

9511 ms. RemoteScriptError:     
9517 ms. RemoteScriptError: from touchAble import touchAble

9523 ms. RemoteScriptError:   File "MIDI Remote Scripts\touchAble\touchAble.py", line 39, in <module>

9527 ms. RemoteScriptError:     
9533 ms. RemoteScriptError: import touchAbleCallbacks

9538 ms. RemoteScriptError:   File "MIDI Remote Scripts\touchAble\touchAbleCallbacks.py", line 35, in <module>

9542 ms. RemoteScriptError:     
9547 ms. RemoteScriptError: import uuid

9554 ms. RemoteScriptError: ImportError
9558 ms. RemoteScriptError: : 
9563 ms. RemoteScriptError: No module named uuid
9568 ms. RemoteScriptError: 

9574 ms. Exception: Traceback (most recent call last):   File "<string>", line 1, in <module>   File "D:\Program Files\Ableton Live\Resources\MIDI Remote Scripts\touchAble\__init__.py", line 33, in <module>     from touchAble import touchAble   File "D:\Program Files\Ableton Live\Resources\MIDI Remote Scripts\touchAble\touchAble.py", line 39, in <module>     import touchAbleCallbacks   File "D:\Program Files\Ableton Live\Resources\MIDI Remote Scripts\touchAble\touchAbleCallbacks.py", line 35, in <module>     import uuid ImportError: No module named uuid 

Looks like a missing dependency.


#8

Bump. Paid a bit of money between Touchable 3 and now Touchable Pro, would like to actually use the software.


#9

Hi there,

same problem at my installation. Same server on Windows but touchable client at android Samsung S2 Tablet.

It works starteing the components in this sequence:

  • Load the ableton live set
  • restart the touchable server
  • restart touchable

But ist is not reliable, sometimes I have to repeat step 2 and 3 until the connection ist established. When the tablet goes to sleep the connection ist lost again.

(Maybe a timeout problem ?)

If you could please analyze and fix it ?

Thanks in advance,
Joerg


#10

Hi. As mentioned above. I also have serious issus with connecting to server. Bought the Android Touchable pro and was fine the first month but since a week ago its impossible connecting to server. Have tried everything to no avail. I also use iphone tp but always thruu usb. So I tried connect over wifi and at beginning same issues. No connect. But when restarting tp over and over again 6 or 7 times, connection where made. But very unreliable and intermittent. Changed back to usb and problem solved. Connecting every time. No issues. Have had some other problem with Touchable pro not updating the userinterface like showing clips made in live 10 and changed names in live not being updated in tp and so on. I wonder if those two issues can be related . The comunictaion beetween app and server and live fails. But of course worst issue is that I cant even connect with my Android Samsung Tab A 2018 model. If android could connect via usb, problem is solved at least temporarily. Using Live 10.0.4, on win 10 pc, latest server, latest Touchable pro. As I see it to rely on connectivity thruu wifi is not practicaly unless you have a wifirouter in your studio and as such only is used for controler functions, not internet and file sharing and so on on the some router. To many things can go wrong with wifi in realtime controling apps. I would never use wifi in a live performance situation when you have no control over the network. So pleeeease implement usb for android as soon as is possible. I want to be able to touch my pad and actually use it. As I have said earlier tp is a marvellous tool but it has to be much more stable in hard use. Regards Elmer


#11

i have the same problem with windows 10 running on both machines. i managed to get it running with rtpmidi & ad-hoc network. it worked maybe for one hour, then suddenly stopped and i am not possible to get it running again. if live and touchable are on the same machine it is working fine…

looking at the other comments i am wondering if it is actually possible to run live and tp on seperate windows machines at the moment. i am starting to get frustrated by the lack of communication / transparency about this. essential information like the lack of usb connection for windows and android is only mentioned in the manual and missing on the homepage. and there is no help on how to set up an ad-hoc network - which is essential if cable connection is impossible.

please add this missing information in the setup guide / faq, and it would be great if you can comment which connections are stable currently, if any. thanks!


#12

Metamo
I feel the same on the subject of connectivity problems. The developers seems to ignore these subjects. I can’t get it. Theres a bunch of communication between users and devs about device editor issues and things like that. No offence, I mean that it should be safe saving templats made, BUT here we are a bunch of Windows 10 and Android Touchable Pro users who CAN NOT CONNECT to server and we have all tried everything imaginable. And the devs don’ reply, not a word. NADA. You could at least communicate that you cant reproduce these errors in your lab, or that you are looking into it as soon as… It almost feels that you think we are idiots that cant fix a proper network and so on. Im really irritated on this subject. People want a refund for TPro and you dont care. Strange behaviour.
PS The solution to put up an Ad-hoc wifi local network is possible on IOS and a win7 servermachine. But this is not possible on Android because of security reasons, its not allowed apparently. I have tried and its not working. So we all users with android or win tp its best to just sell of our pads , and buy a new ipad twice as expensiv as a samsung pad. Its idiotic to say the least.
Regards Elmer


#13

i managed to get the connection working again repeatedly now. but it is still unclear why it crashed. i can reconnect if i restart rtpmidi on the windows computer that is running live and restart the windows-touch device that is running touchable pro (restarting rtp midi or reconnecting to the network is not enough on the touch device). i have also reinstalled rtpmidi on the computer that is running live, so i don’t know if this was also necessary. i noticed rtpmidi needs to show the peer on both devices, sometimes when connection was lost it still showed the peer on one device and seemed to connect but the connection did not work.

i am using a program that is called AdhocManager to create the wireless network on the windows computer. the touch device just connects to this network. if the peer shows in rtpmidi on both devices the connection is actually working.

i understand that providing support for all the different hardware coming with windows/andoid is a lot of work. but as i wrote before i don’t understand the lack of some instability warnings/network guides/support.


#14

Hey guys,

sorry for the silence in this thread - i promise we are not ignoring these issues.
The problem to give support in threads like these is that there are very different issues present.

Let’s break it down:
@con5cience: Please update Live to its latest Version. Anything above 9.6 should be fine, but the latest is the safest bet. You should be able to connect afterwards.

@ivruebj
The best and quickest sequence to start is:

  1. Start the touchAble Server
  2. Start Live
  3. Start app on touch device

The Server creates a virtual midi port and Live sometimes needs to receive a signal via midi to actually recognize it correctly. This is circumvented by starting the Server prior to Live.

@Elmer.Sandland
We’ll definitely implement USB for android in the coming weeks. We had a look at it and it’s similarly done as in iOS so it will hopefully be quick to implement.
Until then we can only recommend using a dedicated Wifi router or creating an AdHoc network on the Mac / Windows Machine that is running Live.
We will update our guides to include setting this up on either System!

@metamo
Windows 10 running on both machines is a special case. It’s a bit counter-intuitive, but you need to install our Server on both machines - the one running Live as well as the one running touchAble Pro.

On the Machine running touchAble Pro the Server can be closed after running it for 10-20 seconds and won’t be needed anymore. It’s simply needed to allow the touchAble Pro app to connect to the localhost & the network.

about rtpMIDI: we only use it’s virtual MIDI driver to create a virtual midi port on the host Windows Machine. It’s not needed to connect actually.
But: If you see rtpMIDI finding the other rtpMIDI installation on the network that means Bonjour works correctly (the discovery method that’s needed to find Hosts & clients on the network) and as touchAble Pro uses the same method it will find its Server as well.

As you noted, creating an Adhoc network is the way to go!

One general note: Please make sure to select the Control Surface ‘Input’ as ‘touchAble Script Input’
if that is set incorrectly, it can explain connection & stability issues as well.

Please keep us posted!
Cheers,
Chris


#15

Hi Chris.
The new Pc server 428 and scripts together with updated Touchable Pro made the difference. All is running smooth now on my Samsung TabA Android 8.1. Cionnects automaticaly every time. Phhhuuu. Thanks for the hard work with the newest release. This wonder app is soon to become really wonder ful.
PS Looking forward to the coming USB feature on Android.

All the best Elmer


#16

Chris.
The improvements list in 428 server and scripts is really massive. Nice! But the connectivity problems is not mentioned in the bugfixes. What did you do, to get all running fine for us on Android? Would be nice to know about the fix so I know where to look if problem occure again. If its related to other applications on the pad or the host computer.

I mean, shall we use Touchable Pro solely and no other servers or virtual midi apps, or controlers, uninstall everything else not related to TP or Zerodebug server?
Regards Elmer