1. The latest Studiomux windows Beta Server link goes to a 404 BEING FIXED!

  2. On the Touchable Pro website page, the Windows sever download link is broken SOLVED!

  3. On the Touchable Pro website page, the Windows server + Apple Driver Download link goes to a 404 SOLVED!

ASAP Please. Thanks!

sorry, our server hasn’t build its update successfully yesterday, touchable links are up again. studiomux links will be fixed this evening… best

Thanks! :smiley:

Hi Pascal. Sorry to bring bad news, but none of the Touchable Pro Server links are working on the website at the time of this message…

hm… that’s weird links are working for me. could you please check if, these links are working (copied from website)?



None of those links work here…in the U.K.

I don’t think it’s at my end…unless something very weird is happening…that is possible tho!

Just checked my virus protection, & it hasn’t blocked anything…we need other people to try them, & report back…

thanks for the feedback, super weird indeed, maybe it’s the cache misdirecting you? could you try with cmd and curl?

curl -o touchAblePro_1.613_x64.exe

Beyond my limited knowledge I’m afraid! Maybe you could just ask a friend who has a Mac/PC to try the links on the website?

Hi Pascal, Looks like it’s something very weird at my end. As a control i tried downloading the installer for something else unrelated & it doesn’t work either. Never had this problem before… ever…will investigate & sort it out…cheers & apologies…!

Something weird had happened to Firefox. A refresh has sorted it out. The coincidence was that the other links were going to a 404, so i assumed your other links were broken when they wouldn’t download. I think they call that SODS LAW! Aplogies for giving you the run arround. I am suitably embarrased!!!

Studiomux Server Beta Link still going to a 404, but will count that as solved as you are fixing it!!!

Onwards & Upwards…!!!