Studiomux won't launch on ipad running IOS 14.6

I have an iPad 9.7 and a new iPad Pro 12.9 4th gen and both are running IOS 14.6. I have not been able to open Studiomux on either iPad. I can open Touchable Pro on them but nothing shows up. My PC is a Windows 10.0.19042 Build 19042 Home with 32GB ram. I am running Ableton Live 11 Suite 11.02. I looked for updates on the iPad and it seems I have the latest released version though it seems there are also beta version but I have not signed up for those. I’ve tried Touchable Server 1.671 as well as the 1.708 beta version and no luck with either one. Studiomux doesn’t open at all on the iPad and iPad Pro. It just hangs.

Please let me know if there are versions that are in the works for Studiomux and Touchable Pro that I can use that will work. I love these apps when they work but it seems like either Windows, Ableton and/or IOS updates keeps breaking these apps so reliability with Studiomux and Touchable has been a long-term problem. I tried to install the iTunes program from your site but Windows tells me that I have the latest version.


sorry for the inconvenience.

We started rewriting studiomux short time before iOS 14 has been released, since our old graphical engine was not supported by iOS 14 anymore. We are still working on the update. Since it is still woring on iOS version lower 14, we didn’t want to release a version, before it is 100% stable. Therefore we decided to create an open beta for studiomux anyone can join without invation (same is true for touchable).

The latest studiomux beta can be downloaded here:

The latest beta studiomux server for windows is avaiable here:

The latest iOS touchAble beta can be downloaded here:

The latest stable server for win was:

Since the USB connection is not working anymore in combination with the latest iTunes we are working on a native USB connection on windows. This is included in win servers from 1.680, but it seems to make trouble for some users. I will let you know, as soon as we got a new working server.



Today I deleted Touchable Pro and Studiomux from my iPad and iPad Pro and reinstalled the latest versions from the App store. I also deleted their servers from my PC and installed the touchAblePro 1.724 and studiomux 5.097 servers. Touchable Pro works on both iPads now but Studiomux still doesn’t work though it doesn’t crash immediately as before. I get a green box from the now VST3 version which says v.5.093 but no devices are shown even though I have Studiomux running on either my ipad or iPad Pro. Do I still need to install iTunes from the Zerodebug site instead of from Apple to get Studiomux to work with this newer version?


No studiomux will now run with any version of iTunes, it uses the same library managment as touchAble does. If you are able to estable a USB connection via touchable, it should work with studiomux, too.

Did you try both apps in one session?